MySQL5.6警告Using a password on the command line interface can be insecure处理方法

警告信息

在mysql5.6版本中,在命令行中出现密码会跳出如下警告信息:

Warning: Using a password on the command line interface can be insecure.

* 在- mysql -u root -p 密码和mysqldump中都会出现上述警告信息。

解决方法

mysql

不要在命令行中使用-p + 密码的方式。

mysql -u root -p 

mysqldump

vim /etc/mysql/my.cnf
[mysqldump]
user=backup_user_name
password=backup_password

文章最后更新时间 : 2020年12月01日 17:33:01

评论已关闭